注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

随波踏浪

----------无痕

 
 
 

日志

 
 
 
 

选股指标  

2013-01-22 13:32:58|  分类: 公式研究 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
双底背离
线柱同时背离
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);
XG1:=MACD<0 AND MACD>MQDZ AND DIFF<0 AND DIFF>DQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0 AND DQDZ<0;
XG:REF(XG1,1)=1 AND MACD>REF(MACD,1);

零轴以上一次金叉
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AA:=CROSS(DIF,DEA) AND DEA>0;
BB:=BARSLAST(CROSS(DEA,DIF)) AND DEA>0; 
CC:=REF(BARSLAST(CROSS(DIF,0))<20,BARSLAST(CROSS(DEA,DIF))+1);
AA AND BB AND CC;


中线掘金

中线选股的要决是:外盘明显小于内盘而股价收阳的股票。

DYNAINFO(22)>=2*DYNAINFO(23) and c>=ref(c,1) and c>o;


均线粘合
M:=1;
M5:=MA(CLOSE,5);
M10:=MA(CLOSE,10);
M20:=MA(CLOSE,20);
K1:=MAX(MAX(M5,M10),MAX(M10,M20));
K2:=MIN(MIN(M5,M10),MIN(M10,M20));
A:=K1/K2<1+0.02*M;
A1:=MA(C,30)>MA(C,60) AND MA(C,60)>MA(C,90);
A2:=(C/REF(C,1)-1)>0.015;
A3:=V>REF(V,1)*1.5 AND V>MA(V,5);
XG:A AND A1 AND A2 AND A3 ;

另外一种写法

A1:=MA(c,5);A2:=MA(c,10);A3:=MA(c,20);A4:=MA(c,30);

A5:=MAX(A1,MAX(A2,MAX(A3,A4)));

A6:=MIN(A1,MIN(A2,MIN(A3,A4)));

(A5/A6)<1.065 AND A1>REF(A1,1)AND A2>REF(A2,1)AND A3>REF(A3,1)AND A4>REF(A4,1);

 

次日涨停

W1:=C=HHV(C,20);

W2:=BARSLAST(W1);

W3:=IF(W2>0,REF(C,W2),REF(C,W2));

W4:=CROSS(C,REF(W3,1));

A3:=V>REF(V,1)*1.5 AND V>MA(V,5);

W4 AND COUNT(W4,5)=1 AND A3 AND C>0;

 

DMI捕捉爆涨股
公式分析:PDI上穿三线,并且涨幅大于5%,并且成交量大于昨日
CROSS("DMI.PDI","DMI.MDI") and CROSS("DMI.PDI","DMI.ADX") and CROSS("DMI.PDI","DMI.ADXR") and C>REF(C,1)*1.05 and VOL>REF(VOL,1);


macd二次金叉

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

MACD二次翻红

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
FH4:=FH1 AND FH2 AND ABS((DIFF-DEA)/C)<0.018;
FH5:=FH1 AND FH2 AND MACD<0.10;
FH3 OR FH4 OR FH5;

DIF下破0轴

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
均线向上:=EMA(C,144)>=REF(EMA(C,144),1) AND  EMA(C,233)>=REF(EMA(C,233),1);
破0轴:均线向上 AND REF(DIFF,1)>0 AND DIFF<0;

MACD0轴附近金叉(特别是0轴之上)
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
CROSS(DIF,DEA) AND DEA>-0.05;

突破历史新高
N:=10;
TJ1:=HHV(HIGH,N)=HHV(HIGH,0) AND BARSCOUNT(CLOSE)>=60;
TJ2:=NOT(DYNAINFO(4)=0) AND NOT(NAMELIKE('S') OR NAMELIKE('*'));
TJ3:=DYNAINFO(39)>0 AND DYNAINFO(39)<60 AND C<30;
TJ1 AND TJ2 AND TJ3;

均线突破
VAR1:=COUNT(CROSS(MA(C,10),C),5)=1 AND CROSS(C, MA(C,10)) AND V>REF(V,1)*1.4;
VAR2:=CROSS(C,MA(C,10)) AND V>REF(V,1)*2;
VAR3:=CAPITAL<8000000;
VAR4:=DYNAINFO(39)>0 AND DYNAINFO(39)<60;{0<市盈率<35}
个股:=(CLOSE-REF(CLOSE,3))/REF(CLOSE,3)*100; 
大盘:=(INDEXC-REF(INDEXC,3))/REF(INDEXC,3)*100; 
强弱值:=个股-大盘;
(VAR1 OR VAR2) AND VAR3 AND VAR4 AND 强弱值>0;

次新股
A:=BARSCOUNT(CLOSE)<100 AND BARSCOUNT(CLOSE)>20;
B:="RSI.RSI1"<50;
AA:=DYNAINFO(39)>0 AND DYNAINFO(39)<60;
BB:=C>0 AND C<70;
A AND B AND AA AND BB;

回档起飞
  1. MM1:=MA(C,60);
  2. MM2:=MA(C,120);
  3. CQXD:=EVERY(MM2<REF(MM2,1),60);
  4. JD:=57.3*ATAN(100*(MM1/REF(MM1,1)-1));
  5. CSFR:=LONGCROSS(C,MM1,5);
  6. FRYL:=BARSLAST(CSFR);
  7. ZG:=HHV(C,FRYL);
  8. ZD:=LLV(C,FRYL);
  9. ZGYL:=BARSLAST(ZG=C);
  10. ZDYL:=BARSLAST(ZD=C);
  11. MZG:=REF(MM1,ZGYL);
  12. MZD:=REF(MM1,ZDYL);
  13. FL:=V>1.25*REF(V,1);
  14. SL:=V<0.75*REF(V,1);
  15. TJ1:=CQXD&&FRYL>ZGYL&&ZGYL>ZDYL&&ZG>1.05*MZG&&ZD>0.95*MZD&&COUNT(C>MM1,FRYL)>5;
  16. TJ2:=EXIST(FL,3)&&COUNT(SL,ZGYL)>0.6*COUNT(FL,ZGYL)&&EXIST(C<REF(ZD,1),2)&&C>REF(C,1)&&C>O&&EVERY(JD>0,3);
  17. OPP:TJ1&&TJ2;

放量突破前期新高
//n:是n天前高点到今天的天数,自己定
//m:量比数自己定
xg:HHV(H,n)=H AND V/REF(MA(V,5),1)>m;

价值系数
V1:=CAPITAL*C*DYNAINFO(39)/10000000;
XG:V1<N AND BARSCOUNT(CLOSE)>=30;

抄底
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),9,1)/SMA(ABS(CLOSE-LC),9,1)*100;
TJ1:=COUNT(RSI<30,7)>0 AND C>0;
TJ2:=DYNAINFO(39)>0 AND DYNAINFO(39)<60;{0<市盈率<60}
TJ3:=CROSS(C,MA(C,9)) AND V>REF(V,1)*1.4;
TJ1  AND TJ2 AND TJ3;

波段底部
TC1:=IF(H=HHV(H,48),H,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=H))+1;
UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
BC1:=IF(L=LLV(L,48),L,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
LP:=CURRBARSCOUNT<=BC2 AND L=LOWER;
去除ST:= IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
去除停牌:=DYNAINFO(4)>0;
DD:=去除ST AND去除停牌;
CC:=BARSCOUNT(CLOSE)>60;
{N日内有涨停的个股, }
N:=10;{这是指10日内,此数可更改}
ZT:=V>REF(V,1)*1.4;
AA:=C/REF(C,1)>=1.03;
EE:=ZT AND AA;
XG:COUNT(LP>0,N)>0 AND DD AND CC AND EE;

平台突破
AL1:=REF(HHV(C,55)/LLV(C,55)<1.25,1) AND C>=REF(C,13);
AL2:= C>O AND V*200/FROMOPEN/REF(MA(V,5),1)>5;
XG:AL1 AND AL2;
  评论这张
 
阅读(205)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017